Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Feb 2004
    Location
    Melbourne
    Posts
    404
    TPP Wholesale WHMCS problem starting 5/2/15
    We use TPP Wholesale as the domain registrar for our WHMCS and starting from 05/02/15 (around midnight) any API function that uses this module simply returns 'Unknown Error' and has nothing in the module log (empty responses)

    Am able to ping/wget the API url from the WHMCS server without issues so it's not network related.

    The only *issue* that I can see is that the API url is https://114.141.204.99/api/query.pl and the SSL cert is obviously not valid for that IP (it's for a hostname). But I'm pretty sure it's always been like that and never a problem.

    We use cloudlinux 6 on the whmcs box but I can't see any recent OS updates that could have anything to do with this.

    Still waiting on TPP support to look into it. The console seems to work without problems just not the API/WHMCS gateway

  2. #2
    Registered User
    Join Date
    Feb 2004
    Location
    Melbourne
    Posts
    404
    Ok it's NOT an issue with the API Url .. as I managed to find an un-encoded tppwregistrar.php at https://code.jd.com/ltxnwt/whmcs/blo...wregistrar.php and modify it slightly for testing purposes to change the IP url to the actual valid ssl hostname.

    Still same (unknown) error.

    I even got rid of the "gethostbyname" function inside it as I recall there was a recent issue with this function in glibc and thought maybe that got patched and is causing this issue ... nope. Even with the 'gethostbyname' function completely disabled, same issue.

    Am I the only person having this issue with TPP Wholesale's WHMCS module ????

  3. #3
    Registered User
    Join Date
    Feb 2004
    Location
    Melbourne
    Posts
    404
    Solutions posted https://forums.whirlpool.net.au/foru...?t=2350020#r15

    WHT-AU pretty dead nowadays huh

  4. #4
    Crucial Cloud Hosting ross-crucial's Avatar
    Join Date
    Jan 2010
    Location
    Sydney, Auistralia
    Posts
    54
    *tumble weed*

  5. #5
    Thankyou for the solution!

  6. #6
    Quote Originally Posted by pixie View Post
    Ok it's NOT an issue with the API Url .. as I managed to find an un-encoded tppwregistrar.php at https://code.jd.com/ltxnwt/whmcs/blo...wregistrar.php and modify it slightly for testing purposes to change the IP url to the actual valid ssl hostname.

    Still same (unknown) error.

    I even got rid of the "gethostbyname" function inside it as I recall there was a recent issue with this function in glibc and thought maybe that got patched and is causing this issue ... nope. Even with the 'gethostbyname' function completely disabled, same issue.

    Am I the only person having this issue with TPP Wholesale's WHMCS module ????
    We use TPP Wholesale and have not had any problems. Sorry. Hope it gets sorted.

Similar Threads

  1. VentraIP Wholesale - Resell domains, hosting and SSL - WHMCS Modules and API
    By Cheyne in forum Australian Related Offers and Requests
    Replies: 3
    Last Post: 20-12-2013, 05:01 PM
  2. VentraIP Wholesale - Resell domains, hosting and SSL - WHMCS Modules and API
    By Cheyne in forum Australian Related Offers and Requests
    Replies: 3
    Last Post: 16-11-2013, 09:12 PM
  3. VentraIP Wholesale - Resell domains, hosting and SSL - WHMCS Modules and API
    By Cheyne in forum Australian Related Offers and Requests
    Replies: 0
    Last Post: 04-11-2013, 01:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •